about summary refs log tree commit diff
path: root/third_party/lisp/let-plus.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/let-plus.nix')
-rw-r--r--third_party/lisp/let-plus.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/third_party/lisp/let-plus.nix b/third_party/lisp/let-plus.nix
new file mode 100644
index 0000000000..3afb640e4e
--- /dev/null
+++ b/third_party/lisp/let-plus.nix
@@ -0,0 +1,20 @@
+{ depot, pkgs, ... }:
+
+let
+  src = pkgs.fetchgit {
+    url = "https://github.com/tpapp/let-plus.git";
+    rev = "7cf18b29ed0fe9c667a9a6a101b08ab9661a59e9";
+    hash = "sha256:1xy3b05dwjddk33mah2jaigm4jzsmrxjcc1d0dhsw0krwgr4450f";
+  };
+in depot.nix.buildLisp.library {
+  name = "let-plus";
+  deps = [
+    depot.third_party.lisp.alexandria
+    depot.third_party.lisp.anaphora
+  ];
+  srcs = [
+    "${src}/package.lisp"
+    "${src}/let-plus.lisp"
+    "${src}/extensions.lisp"
+  ];
+}