about summary refs log tree commit diff
path: root/third_party/lisp/defclass-std.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/defclass-std.nix')
-rw-r--r--third_party/lisp/defclass-std.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/third_party/lisp/defclass-std.nix b/third_party/lisp/defclass-std.nix
new file mode 100644
index 0000000000..c31ddb3c5b
--- /dev/null
+++ b/third_party/lisp/defclass-std.nix
@@ -0,0 +1,16 @@
+# A shortcut macro to write DEFCLASS forms quickly
+# Seems to be unmaintained (since early 2021)
+{ depot, pkgs, ... }:
+
+let src = with pkgs; srcOnly lispPackages.defclass-std;
+in depot.nix.buildLisp.library {
+  name = "defclass-std";
+  deps = with depot.third_party.lisp; [
+    alexandria
+    anaphora
+  ];
+
+  srcs = map (f: src + ("/src/" + f)) [
+    "defclass-std.lisp"
+  ];
+}