about summary refs log tree commit diff
path: root/third_party/lisp/closure-common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/closure-common.nix')
-rw-r--r--third_party/lisp/closure-common.nix12
1 files changed, 2 insertions, 10 deletions
diff --git a/third_party/lisp/closure-common.nix b/third_party/lisp/closure-common.nix
index 591620e487..0856fc9e52 100644
--- a/third_party/lisp/closure-common.nix
+++ b/third_party/lisp/closure-common.nix
@@ -1,17 +1,9 @@
 { depot, pkgs, ... }:
 
 let
-  src = pkgs.fetchFromGitHub {
-    owner = "sharplispers";
-    repo = "closure-common";
-    rev = "e3c5f5f454b72b01b89115e581c3c52a7e201e5c"; # 2018-09-09
-    sha256 = "0k5r2qxn122pxi301ijir3nayi9sg4d7yiy276l36qmzwhp4mg5n";
-  };
-
+  src = with pkgs; srcOnly lispPackages.closure-common;
   getSrcs = builtins.map (p: "${src}/${p}");
-in
-
-depot.nix.buildLisp.library {
+in depot.nix.buildLisp.library {
   name = "closure-common";
 
   # closure-common.asd surpresses some warnings otherwise breaking