about summary refs log tree commit diff
path: root/third_party/lisp/cl-who.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/cl-who.nix')
-rw-r--r--third_party/lisp/cl-who.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/third_party/lisp/cl-who.nix b/third_party/lisp/cl-who.nix
new file mode 100644
index 0000000000..601b09f118
--- /dev/null
+++ b/third_party/lisp/cl-who.nix
@@ -0,0 +1,13 @@
+{ depot, pkgs, ... }:
+
+let src = with pkgs; srcOnly lispPackages.cl-who;
+in depot.nix.buildLisp.library {
+  name = "cl-who";
+
+  srcs = map (f: src + ("/" + f)) [
+    "packages.lisp"
+    "specials.lisp"
+    "util.lisp"
+    "who.lisp"
+  ];
+}