about summary refs log tree commit diff
path: root/third_party/lisp/cl-json.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/cl-json.nix')
-rw-r--r--third_party/lisp/cl-json.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/third_party/lisp/cl-json.nix b/third_party/lisp/cl-json.nix
new file mode 100644
index 0000000000..0c77718ef0
--- /dev/null
+++ b/third_party/lisp/cl-json.nix
@@ -0,0 +1,25 @@
+# JSON encoder & decoder
+{ pkgs, ... }:
+
+let src = pkgs.third_party.fetchFromGitHub {
+  owner = "hankhero";
+  repo = "cl-json";
+  rev = "6dfebb9540bfc3cc33582d0c03c9ec27cb913e79";
+  sha256 = "0fx3m3x3s5ji950yzpazz4s0img3l6b3d6l3jrfjv0lr702496lh";
+};
+in pkgs.nix.buildLisp.library {
+  name = "cl-json";
+  deps = [ pkgs.third_party.lisp.asdf ];
+
+  srcs = [ "${src}/cl-json.asd" ] ++
+  (map (f: src + ("/src/" + f)) [
+    "package.lisp"
+    "common.lisp"
+    "objects.lisp"
+    "camel-case.lisp"
+    "decoder.lisp"
+    "encoder.lisp"
+    "utils.lisp"
+    "json-rpc.lisp"
+  ]);
+}