about summary refs log tree commit diff
path: root/third_party/lisp/cl-colors2.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/cl-colors2.nix')
-rw-r--r--third_party/lisp/cl-colors2.nix11
1 files changed, 4 insertions, 7 deletions
diff --git a/third_party/lisp/cl-colors2.nix b/third_party/lisp/cl-colors2.nix
index c90b8eae01..34201bc2fa 100644
--- a/third_party/lisp/cl-colors2.nix
+++ b/third_party/lisp/cl-colors2.nix
@@ -1,10 +1,6 @@
+{ depot, pkgs, ... }:
 
-{ depot, ... }:
-
-let src = builtins.fetchGit {
-  url = "https://notabug.org/cage/cl-colors2.git";
-  rev = "795aedee593b095fecde574bd999b520dd03ed24";
-};
+let src = with pkgs; srcOnly lispPackages.cl-colors2;
 in depot.nix.buildLisp.library {
   name = "cl-colors2";
   deps = with depot.third_party.lisp; [
@@ -15,7 +11,8 @@ in depot.nix.buildLisp.library {
   srcs = map (f: src + ("/" + f)) [
     "package.lisp"
     "colors.lisp"
-    "colornames.lisp"
+    "colornames-x11.lisp"
+    "colornames-svg.lisp"
     "hexcolors.lisp"
   ];
 }