about summary refs log tree commit diff
path: root/third_party/lisp/cl-colors.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/cl-colors.nix')
-rw-r--r--third_party/lisp/cl-colors.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/third_party/lisp/cl-colors.nix b/third_party/lisp/cl-colors.nix
new file mode 100644
index 0000000000..71f78e424e
--- /dev/null
+++ b/third_party/lisp/cl-colors.nix
@@ -0,0 +1,21 @@
+{ depot, pkgs, ... }:
+
+let
+  src = pkgs.fetchgit {
+    url = "https://github.com/tpapp/cl-colors.git";
+    rev = "827410584553f5c717eec6182343b7605f707f75";
+    hash = "sha256:0l446lday4hybsm9bq3jli97fvv8jb1d33abg79vbylpwjmf3y9a";
+  };
+in depot.nix.buildLisp.library {
+  name = "cl-colors";
+  deps = [
+    depot.third_party.lisp.alexandria
+    depot.third_party.lisp.let-plus
+  ];
+  srcs = [
+    "${src}/package.lisp"
+    "${src}/colors.lisp"
+    "${src}/colornames.lisp"
+    "${src}/hexcolors.lisp"
+  ];
+}