about summary refs log tree commit diff
path: root/third_party/lisp/cl-base64.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/cl-base64.nix')
-rw-r--r--third_party/lisp/cl-base64.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/third_party/lisp/cl-base64.nix b/third_party/lisp/cl-base64.nix
new file mode 100644
index 0000000000..c4dc9ca2c7
--- /dev/null
+++ b/third_party/lisp/cl-base64.nix
@@ -0,0 +1,17 @@
+# Base64 encoding for Common Lisp
+{ pkgs, ... }:
+
+let src = builtins.fetchGit {
+  url = "http://git.kpe.io/cl-base64.git";
+  rev = "fc62a5342445d4ec1dd44e95f7dc513473a8c89a";
+};
+in pkgs.nix.buildLisp.library {
+  name = "cl-base64";
+  srcs = [
+    (src + "/package.lisp")
+    (src + "/encode.lisp")
+    (src + "/decode.lisp")
+  ];
+}
+
+