about summary refs log tree commit diff
path: root/third_party/lisp/cl-base64.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/cl-base64.nix')
-rw-r--r--third_party/lisp/cl-base64.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/third_party/lisp/cl-base64.nix b/third_party/lisp/cl-base64.nix
new file mode 100644
index 0000000000..08055a0471
--- /dev/null
+++ b/third_party/lisp/cl-base64.nix
@@ -0,0 +1,14 @@
+# Base64 encoding for Common Lisp
+{ depot, pkgs, ... }:
+
+let src = with pkgs; srcOnly lispPackages.cl-base64;
+in depot.nix.buildLisp.library {
+  name = "cl-base64";
+  srcs = [
+    (src + "/package.lisp")
+    (src + "/encode.lisp")
+    (src + "/decode.lisp")
+  ];
+}
+
+