about summary refs log tree commit diff
path: root/third_party/lisp/cl-arrows.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/cl-arrows.nix')
-rw-r--r--third_party/lisp/cl-arrows.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/third_party/lisp/cl-arrows.nix b/third_party/lisp/cl-arrows.nix
new file mode 100644
index 0000000000..778adbf69c
--- /dev/null
+++ b/third_party/lisp/cl-arrows.nix
@@ -0,0 +1,16 @@
+{ depot, pkgs, ... }:
+
+let
+  src = pkgs.fetchgit {
+    url = "https://github.com/nightfly19/cl-arrows.git";
+    rev = "cbb46b69a7de40f1161c9caaf6cef93b3af9994f";
+    hash = "sha256:0la2vr10510vmx29w9p3sj1qi1sych0crcpy4kdgxzn8m7kqlli0";
+  };
+in depot.nix.buildLisp.library {
+  name = "cl-arrows";
+  deps = [];
+  srcs = [
+    "${src}/packages.lisp"
+    "${src}/arrows.lisp"
+  ];
+}