about summary refs log tree commit diff
path: root/third_party/lisp/chipz.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/chipz.nix')
-rw-r--r--third_party/lisp/chipz.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/third_party/lisp/chipz.nix b/third_party/lisp/chipz.nix
index 5a8c39dc05..8f29792bc1 100644
--- a/third_party/lisp/chipz.nix
+++ b/third_party/lisp/chipz.nix
@@ -1,15 +1,17 @@
 # Common Lisp library for decompressing deflate, zlib, gzip, and bzip2 data
 { pkgs, ... }:
 
+with pkgs.nix;
+
 let src = pkgs.third_party.fetchFromGitHub {
   owner = "froydnj";
   repo = "chipz";
   rev = "75dfbc660a5a28161c57f115adf74c8a926bfc4d";
   sha256 = "0plx4rs39zbs4gjk77h4a2q11zpy75fh9v8hnxrvsf8fnakajhwg";
 };
-in pkgs.nix.buildLisp.library {
+in buildLisp.library {
   name = "chipz";
-  deps = with pkgs.third_party.lisp; [ asdf ];
+  deps = [ (buildLisp.bundled "asdf") ];
 
   srcs = map (f: src + ("/" + f)) [
     "chipz.asd"