about summary refs log tree commit diff
path: root/third_party/lisp/chipz.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/chipz.nix')
-rw-r--r--third_party/lisp/chipz.nix10
1 files changed, 4 insertions, 6 deletions
diff --git a/third_party/lisp/chipz.nix b/third_party/lisp/chipz.nix
index dfbf32b094..2a68d3b1f8 100644
--- a/third_party/lisp/chipz.nix
+++ b/third_party/lisp/chipz.nix
@@ -1,17 +1,15 @@
 # Common Lisp library for decompressing deflate, zlib, gzip, and bzip2 data
-{ depot, ... }:
+{ depot, pkgs, ... }:
 
-with depot.nix;
-
-let src = depot.third_party.fetchFromGitHub {
+let src = pkgs.fetchFromGitHub {
   owner = "froydnj";
   repo = "chipz";
   rev = "75dfbc660a5a28161c57f115adf74c8a926bfc4d";
   sha256 = "0plx4rs39zbs4gjk77h4a2q11zpy75fh9v8hnxrvsf8fnakajhwg";
 };
-in buildLisp.library {
+in depot.nix.buildLisp.library {
   name = "chipz";
-  deps = [ (buildLisp.bundled "asdf") ];
+  deps = [ (depot.nix.buildLisp.bundled "asdf") ];
 
   srcs = map (f: src + ("/" + f)) [
     "chipz.asd"