about summary refs log tree commit diff
path: root/third_party/lisp/cffi.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/cffi.nix')
-rw-r--r--third_party/lisp/cffi.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/third_party/lisp/cffi.nix b/third_party/lisp/cffi.nix
index 556dee0676..a01dab8924 100644
--- a/third_party/lisp/cffi.nix
+++ b/third_party/lisp/cffi.nix
@@ -1,18 +1,19 @@
 # CFFI purports to be the Common Foreign Function Interface.
 { pkgs, ... }:
 
+with pkgs.nix;
 let src = builtins.fetchGit {
   url = "https://github.com/cffi/cffi.git";
   rev = "5e838bf46d0089c43ebd3ea014a207c403e29c61";
 };
-in pkgs.nix.buildLisp.library {
+in buildLisp.library {
   name = "cffi";
   deps = with pkgs.third_party.lisp; [
     alexandria
-    asdf
     babel
     trivial-features
-    uiop
+    (buildLisp.bundled "asdf")
+    (buildLisp.bundled "uiop")
   ];
 
   srcs = map (f: src + ("/src/" + f)) [