about summary refs log tree commit diff
path: root/third_party/lisp/anaphora.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/anaphora.nix')
-rw-r--r--third_party/lisp/anaphora.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/third_party/lisp/anaphora.nix b/third_party/lisp/anaphora.nix
new file mode 100644
index 0000000000..c079943e67
--- /dev/null
+++ b/third_party/lisp/anaphora.nix
@@ -0,0 +1,13 @@
+{ depot, pkgs, ... }:
+
+let src = with pkgs; srcOnly lispPackages.anaphora;
+in depot.nix.buildLisp.library {
+  name = "anaphora";
+
+  srcs = map (f: src + ("/" + f)) [
+    "packages.lisp"
+    "early.lisp"
+    "symbolic.lisp"
+    "anaphora.lisp"
+  ];
+}