about summary refs log tree commit diff
path: root/third_party/lisp/anaphora.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/anaphora.nix')
-rw-r--r--third_party/lisp/anaphora.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/third_party/lisp/anaphora.nix b/third_party/lisp/anaphora.nix
new file mode 100644
index 0000000000..d2356f7b05
--- /dev/null
+++ b/third_party/lisp/anaphora.nix
@@ -0,0 +1,18 @@
+{ depot, pkgs, ... }:
+
+let src = pkgs.fetchFromGitHub {
+    owner = "tokenrove";
+    repo = "anaphora";
+    rev = "018590df36ffb30ece561fb28ea6521363efc6e2";
+    sha256 = "0pq6y5swvrjd0kjs2dl2648s13s0pzxin0chrq35jam8jrci3kd1";
+  };
+in depot.nix.buildLisp.library {
+  name = "anaphora";
+
+  srcs = map (f: src + ("/" + f)) [
+    "packages.lisp"
+    "early.lisp"
+    "symbolic.lisp"
+    "anaphora.lisp"
+  ];
+}