about summary refs log tree commit diff
path: root/third_party/lisp/anaphora.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/anaphora.nix')
-rw-r--r--third_party/lisp/anaphora.nix23
1 files changed, 12 insertions, 11 deletions
diff --git a/third_party/lisp/anaphora.nix b/third_party/lisp/anaphora.nix
index bf4bf663f4d4..d2356f7b05ea 100644
--- a/third_party/lisp/anaphora.nix
+++ b/third_party/lisp/anaphora.nix
@@ -1,17 +1,18 @@
-{ depot, ... }:
+{ depot, pkgs, ... }:
 
-let
-  src = builtins.fetchGit {
-    url = "https://github.com/tokenrove/anaphora.git";
-    rev = "aeace4c68cf55098a67112750b28f8f2dc6d0e30";
+let src = pkgs.fetchFromGitHub {
+    owner = "tokenrove";
+    repo = "anaphora";
+    rev = "018590df36ffb30ece561fb28ea6521363efc6e2";
+    sha256 = "0pq6y5swvrjd0kjs2dl2648s13s0pzxin0chrq35jam8jrci3kd1";
   };
 in depot.nix.buildLisp.library {
   name = "anaphora";
-  deps = [];
-  srcs = [
-    "${src}/packages.lisp"
-    "${src}/early.lisp"
-    "${src}/symbolic.lisp"
-    "${src}/anaphora.lisp"
+
+  srcs = map (f: src + ("/" + f)) [
+    "packages.lisp"
+    "early.lisp"
+    "symbolic.lisp"
+    "anaphora.lisp"
   ];
 }