about summary refs log tree commit diff
path: root/third_party/lisp/alexandria.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/alexandria.nix')
-rw-r--r--third_party/lisp/alexandria.nix32
1 files changed, 0 insertions, 32 deletions
diff --git a/third_party/lisp/alexandria.nix b/third_party/lisp/alexandria.nix
deleted file mode 100644
index dbe0554d62..0000000000
--- a/third_party/lisp/alexandria.nix
+++ /dev/null
@@ -1,32 +0,0 @@
-# Alexandria is one of the foundational Common Lisp libraries that
-# pretty much everything depends on:
-#
-# https://common-lisp.net/project/alexandria/
-{ pkgs, ... }:
-
-let src = builtins.fetchGit {
-  url = "https://gitlab.common-lisp.net/alexandria/alexandria";
-  rev = "1224346a48770dc07a68ef3e612b9ac3d611eb07";
-};
-in pkgs.nix.buildLisp.library {
-  name = "alexandria";
-  srcs = map (f: src + ("/" + f)) [
-    "package.lisp"
-    "definitions.lisp"
-    "binding.lisp"
-    "strings.lisp"
-    "conditions.lisp"
-    "symbols.lisp"
-    "macros.lisp"
-    "functions.lisp"
-    "io.lisp"
-    "hash-tables.lisp"
-    "control-flow.lisp"
-    "lists.lisp"
-    "types.lisp"
-    "arrays.lisp"
-    "sequences.lisp"
-    "numbers.lisp"
-    "features.lisp"
-  ];
-}