about summary refs log tree commit diff
path: root/third_party/josh/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/josh/default.nix')
-rw-r--r--third_party/josh/default.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/third_party/josh/default.nix b/third_party/josh/default.nix
new file mode 100644
index 000000000000..9b529304ce2f
--- /dev/null
+++ b/third_party/josh/default.nix
@@ -0,0 +1,29 @@
+# https://github.com/esrlabs/josh
+{ depot, pkgs, ... }:
+
+let
+  src = pkgs.fetchFromGitHub {
+    owner = "esrlabs";
+    repo = "josh";
+    rev = "4a70f2914260066b2db44f4cabe9b80acdd556af";
+    sha256 = "0gwn3daj24538h5ddksvnyhq4lyjh0br9k49jhbd7r1sm6ly2cwl";
+  };
+in depot.third_party.naersk.buildPackage {
+  inherit src;
+
+  buildInputs = with pkgs; [
+    libgit2
+    openssl
+    pkgconfig
+  ];
+
+  cargoBuildOptions = x: x ++ [
+    "-p" "josh"
+    "-p" "josh-proxy"
+    "-p" "josh-ui"
+  ];
+
+  overrideMain = x: {
+    patches = [ ./0001-replace-mentions-of-master-with-canon.patch ];
+  };
+}