about summary refs log tree commit diff
path: root/third_party/gopkgs/golang.org/x/oauth2/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/gopkgs/golang.org/x/oauth2/default.nix')
-rw-r--r--third_party/gopkgs/golang.org/x/oauth2/default.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/third_party/gopkgs/golang.org/x/oauth2/default.nix b/third_party/gopkgs/golang.org/x/oauth2/default.nix
new file mode 100644
index 0000000000..f5e783b6d1
--- /dev/null
+++ b/third_party/gopkgs/golang.org/x/oauth2/default.nix
@@ -0,0 +1,14 @@
+{ pkgs, ... }:
+
+pkgs.buildGo.external {
+  path = "golang.org/x/oauth2";
+  src = builtins.fetchGit {
+    url = "https://go.googlesource.com/oauth2";
+    rev = "858c2ad4c8b6c5d10852cb89079f6ca1c7309787";
+  };
+
+  deps = with pkgs.third_party; map (p: p.gopkg) [
+    gopkgs."golang.org".x.net.context.ctxhttp
+    gopkgs."cloud.google.com".go.compute.metadata
+  ];
+}