about summary refs log tree commit diff
path: root/third_party/glog/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/glog/default.nix')
-rw-r--r--third_party/glog/default.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/third_party/glog/default.nix b/third_party/glog/default.nix
new file mode 100644
index 0000000000..cebb71c290
--- /dev/null
+++ b/third_party/glog/default.nix
@@ -0,0 +1,18 @@
+{ pkgs, lib, ... }:
+
+let inherit (pkgs) llvmPackages cmake;
+in llvmPackages.libcxxStdenv.mkDerivation {
+  name = "glog";
+  version = "20200527-unstable";
+  src = ./.;
+
+  nativeBuildInputs = [ cmake ];
+  cmakeFlags = [ "-WITH_GFLAGS=OFF" ];
+
+  meta = with lib; {
+    homepage = "https://github.com/google/glog";
+    license = licenses.bsd3;
+    description = "Library for application-level logging";
+    platforms = platforms.unix;
+  };
+}