about summary refs log tree commit diff
path: root/third_party/git/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/git/default.nix')
-rw-r--r--third_party/git/default.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/third_party/git/default.nix b/third_party/git/default.nix
new file mode 100644
index 0000000000..eed07b5616
--- /dev/null
+++ b/third_party/git/default.nix
@@ -0,0 +1,9 @@
+# git with custom patches. This is also used by cgit via
+# `pkgs.srcOnly`.
+{ pkgs, ... }:
+
+pkgs.git.overrideAttrs (old: {
+  patches = (old.patches or [ ]) ++ [
+    ./0001-feat-third_party-git-date-add-dottime-format.patch
+  ];
+})