about summary refs log tree commit diff
path: root/third_party/gerrit_plugins/builder.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/gerrit_plugins/builder.nix')
-rw-r--r--third_party/gerrit_plugins/builder.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/third_party/gerrit_plugins/builder.nix b/third_party/gerrit_plugins/builder.nix
index 7676f50208..ff1754e088 100644
--- a/third_party/gerrit_plugins/builder.nix
+++ b/third_party/gerrit_plugins/builder.nix
@@ -7,6 +7,7 @@
     overlayPluginCmd ? ''
       cp -R "${src}" "$out/plugins/${name}"
     '',
+    postPatch ? "",
   }: ((depot.third_party.gerrit.override {
     name = "${name}.jar";
 
@@ -24,5 +25,9 @@
     installPhase = ''
       cp "bazel-bin/plugins/${name}/${name}.jar" "$out"
     '';
+    postPatch = if super ? postPatch then ''
+      ${super.postPatch}
+      ${postPatch}
+    '' else postPatch;
   }));
 }