about summary refs log tree commit diff
path: root/third_party/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/default.nix')
-rw-r--r--third_party/default.nix18
1 files changed, 0 insertions, 18 deletions
diff --git a/third_party/default.nix b/third_party/default.nix
index c0a8b4df5d..774e634f9c 100644
--- a/third_party/default.nix
+++ b/third_party/default.nix
@@ -47,24 +47,6 @@ in exposed.lib.fix(self: exposed // {
 
   };
 
-  # binary releases of dhall tools, since the build in nixpkgs is broken most of the time.
-  # The binaries are also fully static builds, instead of the half-static crap that nixpkgs produces.
-  easy-dhall-nix =
-    import (builtins.fetchTarball {
-      url = "https://github.com/justinwoo/easy-dhall-nix/archive/eae7f64c4d6c70681e5a56c84198236930ba425e.tar.gz";
-      sha256 = "1y2x15v8a679vlpxazjpibfwajp6zph60f8wjcm4xflbvazk0dx7";
-    }) { pkgs = nixpkgs; };
-
-  dhall = self.easy-dhall-nix.dhall-simple;
-  dhall-bash = self.easy-dhall-nix.dhall-bash-simple;
-  dhall-docs = self.easy-dhall-nix.dhall-docs-simple;
-  dhall-json = self.easy-dhall-nix.dhall-json-simple;
-  dhall-lsp-server = self.easy-dhall-nix.dhall-lsp-simple;
-  dhall-nix = self.easy-dhall-nix.dhall-nix-simple;
-  # not yet in dhall-simple
-  # dhall-nixpkgs = self.easy-dhall-nix.dhall-nixpkgs-simple;
-  dhall-yaml = self.easy-dhall-nix.dhall-yaml-simple;
-
   # Use LLVM 11
   llvmPackages = nixpkgs.llvmPackages_11;
   clangStdenv = nixpkgs.llvmPackages_11.stdenv;