about summary refs log tree commit diff
path: root/third_party/abseil_cpp/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/abseil_cpp/default.nix')
-rw-r--r--third_party/abseil_cpp/default.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/third_party/abseil_cpp/default.nix b/third_party/abseil_cpp/default.nix
new file mode 100644
index 000000000000..66ab4f6ba143
--- /dev/null
+++ b/third_party/abseil_cpp/default.nix
@@ -0,0 +1,31 @@
+{ pkgs, lib, ... }:
+
+let inherit (pkgs) cmake fullLlvm11Stdenv;
+in pkgs.abseil-cpp.override {
+  stdenv = fullLlvm11Stdenv;
+  cxxStandard = "17";
+}
+
+/* TODO(tazjin): update abseil subtree
+
+fullLlvm11Stdenv.mkDerivation rec {
+  pname = "abseil-cpp";
+  version = "20200519-768eb2ca+tvl-1";
+  src = ./.;
+  nativeBuildInputs = [ cmake ];
+  # TODO: run tests
+  # doCheck = true;
+
+  cmakeFlags = [
+    "-DCMAKE_CXX_STANDARD=17"
+    #"-DABSL_RUN_TESTS=1"
+  ];
+
+  meta = with lib; {
+    description = "An open-source collection of C++ code designed to augment the C++ standard library";
+    homepage = https://abseil.io/;
+    license = licenses.asl20;
+    maintainers = [ maintainers.andersk ];
+  };
+}
+*/