about summary refs log tree commit diff
path: root/third_party/abseil_cpp/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/abseil_cpp/default.nix')
-rw-r--r--third_party/abseil_cpp/default.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/third_party/abseil_cpp/default.nix b/third_party/abseil_cpp/default.nix
new file mode 100644
index 000000000000..ec2e996d6a45
--- /dev/null
+++ b/third_party/abseil_cpp/default.nix
@@ -0,0 +1,16 @@
+{ pkgs, lib, ... }:
+
+let inherit (pkgs) cmake llvmPackages;
+in llvmPackages.libcxxStdenv.mkDerivation rec {
+  pname = "abseil-cpp";
+  version = "20200519-768eb2ca";
+  src = ./.;
+  nativeBuildInputs = [ cmake ];
+
+  meta = with lib; {
+    description = "An open-source collection of C++ code designed to augment the C++ standard library";
+    homepage = https://abseil.io/;
+    license = licenses.asl20;
+    maintainers = [ maintainers.andersk ];
+  };
+}