about summary refs log tree commit diff
path: root/third_party/abseil_cpp/absl/memory/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/abseil_cpp/absl/memory/CMakeLists.txt')
-rw-r--r--third_party/abseil_cpp/absl/memory/CMakeLists.txt55
1 files changed, 55 insertions, 0 deletions
diff --git a/third_party/abseil_cpp/absl/memory/CMakeLists.txt b/third_party/abseil_cpp/absl/memory/CMakeLists.txt
new file mode 100644
index 0000000000..78fb7e1b31
--- /dev/null
+++ b/third_party/abseil_cpp/absl/memory/CMakeLists.txt
@@ -0,0 +1,55 @@
+#
+# Copyright 2017 The Abseil Authors.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+#      https://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+absl_cc_library(
+  NAME
+    memory
+  HDRS
+    "memory.h"
+  COPTS
+    ${ABSL_DEFAULT_COPTS}
+  DEPS
+    absl::core_headers
+    absl::meta
+  PUBLIC
+)
+
+absl_cc_test(
+  NAME
+    memory_test
+  SRCS
+    "memory_test.cc"
+  COPTS
+    ${ABSL_TEST_COPTS}
+  DEPS
+    absl::memory
+    absl::core_headers
+    gmock_main
+)
+
+absl_cc_test(
+  NAME
+    memory_exception_safety_test
+  SRCS
+    "memory_exception_safety_test.cc"
+  COPTS
+    ${ABSL_TEST_COPTS}
+  DEPS
+    absl::memory
+    absl::config
+    absl::exception_safety_testing
+    gmock_main
+)