about summary refs log tree commit diff
path: root/third_party/abseil_cpp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/abseil_cpp/CMakeLists.txt')
-rw-r--r--third_party/abseil_cpp/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/third_party/abseil_cpp/CMakeLists.txt b/third_party/abseil_cpp/CMakeLists.txt
index 1ef35cfd22..d6f24a572c 100644
--- a/third_party/abseil_cpp/CMakeLists.txt
+++ b/third_party/abseil_cpp/CMakeLists.txt
@@ -102,10 +102,8 @@ if(${ABSL_RUN_TESTS})
   # on the command line
   include(CTest)
   enable_testing()
-endif()
 
-## check targets
-if(BUILD_TESTING)
+  ## check targets
   if (NOT ABSL_USE_EXTERNAL_GOOGLETEST)
     set(absl_gtest_build_dir ${CMAKE_BINARY_DIR}/googletest-build)
     if(${ABSL_USE_GOOGLETEST_HEAD})
@@ -177,5 +175,7 @@ if(ABSL_ENABLE_INSTALL)
     FILES_MATCHING
       PATTERN "*.inc"
       PATTERN "*.h"
-  )
+      PATTERN "copts" EXCLUDE
+      PATTERN "testdata" EXCLUDE
+    )
 endif()  # ABSL_ENABLE_INSTALL