about summary refs log tree commit diff
path: root/tests/timeout.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/timeout.nix')
-rw-r--r--tests/timeout.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/timeout.nix b/tests/timeout.nix
index 1f3f23f16a98..540fba934ff6 100644
--- a/tests/timeout.nix
+++ b/tests/timeout.nix
@@ -17,4 +17,12 @@ with import ./config.nix;
     '';
   };
 
+  closeLog = mkDerivation {
+    name = "silent";
+    buildCommand = ''
+      exec > /dev/null 2>&1
+      sleep 1000000000
+    '';
+  };
+
 }