about summary refs log tree commit diff
path: root/tests/timeout.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/timeout.nix')
-rw-r--r--tests/timeout.nix20
1 files changed, 17 insertions, 3 deletions
diff --git a/tests/timeout.nix b/tests/timeout.nix
index b41368bb38e2..1f3f23f16a98 100644
--- a/tests/timeout.nix
+++ b/tests/timeout.nix
@@ -1,6 +1,20 @@
 with import ./config.nix;
 
-mkDerivation {
-  name = "timeout";
-  builder = ./timeout.builder.sh;
+{
+
+  infiniteLoop = mkDerivation {
+    name = "timeout";
+    buildCommand = ''
+      echo "‘timeout’ builder entering an infinite loop"
+      while true ; do echo -n .; done
+    '';
+  };
+
+  silent = mkDerivation {
+    name = "silent";
+    buildCommand = ''
+      sleep 60
+    '';
+  };
+
 }