about summary refs log tree commit diff
path: root/tests/remote-builds.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/remote-builds.nix')
-rw-r--r--tests/remote-builds.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/tests/remote-builds.nix b/tests/remote-builds.nix
index 39bd090e43e7..58a26d8b6182 100644
--- a/tests/remote-builds.nix
+++ b/tests/remote-builds.nix
@@ -85,7 +85,10 @@ in
       }
 
       # Perform a build and check that it was performed on the slave.
-      my $out = $client->succeed("nix-build ${expr nodes.client.config 1}");
+      my $out = $client->succeed(
+        "nix-build ${expr nodes.client.config 1} 2> build-output",
+        "grep -q Hello build-output"
+      );
       $slave1->succeed("test -e $out");
 
       # And a parallel build.