about summary refs log tree commit diff
path: root/tests/negative-caching.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/negative-caching.nix')
-rw-r--r--tests/negative-caching.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/tests/negative-caching.nix b/tests/negative-caching.nix
new file mode 100644
index 0000000000..10df67a748
--- /dev/null
+++ b/tests/negative-caching.nix
@@ -0,0 +1,21 @@
+with import ./config.nix;
+
+rec {
+
+  fail = mkDerivation {
+    name = "fail";
+    builder = builtins.toFile "builder.sh" "echo FAIL; exit 1";
+  };
+
+  succeed = mkDerivation {
+    name = "succeed";
+    builder = builtins.toFile "builder.sh" "echo SUCCEED; mkdir $out";
+  };
+
+  depOnFail = mkDerivation {
+    name = "dep-on-fail";
+    builder = builtins.toFile "builder.sh" "echo URGH; mkdir $out";
+    inputs = [fail succeed];
+  };
+
+}