about summary refs log tree commit diff
path: root/tests/lang/lib.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/lang/lib.nix')
-rw-r--r--tests/lang/lib.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/lang/lib.nix b/tests/lang/lib.nix
index ec705299a7a9..e508f28ba53f 100644
--- a/tests/lang/lib.nix
+++ b/tests/lang/lib.nix
@@ -10,6 +10,8 @@ rec {
   concat =
     fold (x: y: x + y) "";
 
+  and = fold (x: y: x && y) true;
+
   flatten = x:
     if isList x
     then fold (x: y: (flatten x) ++ y) [] x