about summary refs log tree commit diff
path: root/tests/lang/lib.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/lang/lib.nix')
-rw-r--r--tests/lang/lib.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/lang/lib.nix b/tests/lang/lib.nix
index 882005dc1b5c..262cdd7e8fd0 100644
--- a/tests/lang/lib.nix
+++ b/tests/lang/lib.nix
@@ -17,7 +17,7 @@ rec {
     then fold (x: y: (flatten x) ++ y) [] x
     else [x];
 
-  sum = fold (x: y: add x y) 0;
+  sum = foldl' (x: y: add x y) 0;
 
   hasSuffix = ext: fileName:
     let lenFileName = stringLength fileName;