about summary refs log tree commit diff
path: root/tests/lang/eval-okay-xml.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/lang/eval-okay-xml.nix')
-rw-r--r--tests/lang/eval-okay-xml.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/tests/lang/eval-okay-xml.nix b/tests/lang/eval-okay-xml.nix
new file mode 100644
index 000000000000..b9389bfae759
--- /dev/null
+++ b/tests/lang/eval-okay-xml.nix
@@ -0,0 +1,19 @@
+rec {
+
+  x = 123;
+
+  a = "foo";
+
+  b = "bar";
+
+  c = "foo" + "bar";
+
+  f = {z, x, y}: if y then x else z;
+
+  id = x: x;
+
+  at = args@{x, y, z}: x;
+
+  ellipsis = {x, y, z, ...}: x;
+
+}