about summary refs log tree commit diff
path: root/tests/lang/eval-okay-with.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/lang/eval-okay-with.nix')
-rw-r--r--tests/lang/eval-okay-with.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/lang/eval-okay-with.nix b/tests/lang/eval-okay-with.nix
new file mode 100644
index 000000000000..ea4ea612dec3
--- /dev/null
+++ b/tests/lang/eval-okay-with.nix
@@ -0,0 +1,13 @@
+let {
+
+  a = "xyzzy";
+
+  as = {
+    a = "foo";
+    b = "bar";
+  };
+
+  x = with as; a + b;
+
+  body = x;
+}