about summary refs log tree commit diff
path: root/tests/lang/eval-okay-with.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/lang/eval-okay-with.nix')
-rw-r--r--tests/lang/eval-okay-with.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/tests/lang/eval-okay-with.nix b/tests/lang/eval-okay-with.nix
index ea4ea612dec3..033e8d3aba57 100644
--- a/tests/lang/eval-okay-with.nix
+++ b/tests/lang/eval-okay-with.nix
@@ -7,7 +7,13 @@ let {
     b = "bar";
   };
 
+  bs = {
+    a = "bar";
+  };
+
   x = with as; a + b;
 
-  body = x;
+  y = with as; with bs; a + b;
+
+  body = x + y;
 }