about summary refs log tree commit diff
path: root/tests/lang/eval-okay-regex-match.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/lang/eval-okay-regex-match.nix')
-rw-r--r--tests/lang/eval-okay-regex-match.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/tests/lang/eval-okay-regex-match.nix b/tests/lang/eval-okay-regex-match.nix
index ae6501532d11..273e2590713e 100644
--- a/tests/lang/eval-okay-regex-match.nix
+++ b/tests/lang/eval-okay-regex-match.nix
@@ -17,8 +17,11 @@ assert  matches "fo+" "foo";
 assert  matches "fo{1,2}" "foo";
 assert !matches "fo{1,2}" "fooo";
 assert !matches "fo*" "foobar";
+assert  matches "[[:space:]]+([^[:space:]]+)[[:space:]]+" "  foo   ";
+assert !matches "[[:space:]]+([[:upper:]]+)[[:space:]]+" "  foo   ";
 
 assert match "(.*)\\.nix" "foobar.nix" == [ "foobar" ];
+assert match "[[:space:]]+([[:upper:]]+)[[:space:]]+" "  FOO   " == [ "FOO" ];
 
 assert splitFN "/path/to/foobar.nix" == [ "/path/to/" "/path/to" "foobar" "nix" ];
 assert splitFN "foobar.cc" == [ null null "foobar" "cc" ];