about summary refs log tree commit diff
path: root/tests/lang/eval-okay-patterns.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/lang/eval-okay-patterns.nix')
-rw-r--r--tests/lang/eval-okay-patterns.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/tests/lang/eval-okay-patterns.nix b/tests/lang/eval-okay-patterns.nix
index bcb9f3842e47..c233c406c766 100644
--- a/tests/lang/eval-okay-patterns.nix
+++ b/tests/lang/eval-okay-patterns.nix
@@ -8,9 +8,12 @@ let
 
   i = args@args2: args.x + args2.y;
 
+  j = {x, y, z, ...}: x + y + z;
+
 in
   f {x = "a"; y = "b"; z = "c";} +
   g {x = "x"; y = "y"; z = "z";} +
   h {x = "D";} +
   h {x = "D"; y = "E"; z = "F";} +
-  i {x = "g"; y = "h";}
+  i {x = "g"; y = "h";} +
+  j {x = "i"; y = "j"; z = "k"; bla = "bla"; foo = "bar";}