about summary refs log tree commit diff
path: root/tests/lang/eval-okay-listtoattrs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/lang/eval-okay-listtoattrs.nix')
-rw-r--r--tests/lang/eval-okay-listtoattrs.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/lang/eval-okay-listtoattrs.nix b/tests/lang/eval-okay-listtoattrs.nix
new file mode 100644
index 0000000000..d5cd726b0c
--- /dev/null
+++ b/tests/lang/eval-okay-listtoattrs.nix
@@ -0,0 +1,10 @@
+# this test shows how to use listToAttrs and that evaluation is still lazy (throw isn't called)
+with import ./lib.nix;
+
+let 
+  asi = name: value : { inherit name value; };
+  list = [ ( asi "a" "A" ) ( asi "b" "B" ) ];
+  a = builtins.listToAttrs list;
+  b = builtins.listToAttrs ( list ++ list );
+  r = builtins.listToAttrs [ (asi "result" [ a b ]) ( asi "throw" (throw "this should not be thrown")) ];
+in concat (map (x: x.a) r.result)