about summary refs log tree commit diff
path: root/tests/lang/eval-okay-hash.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/lang/eval-okay-hash.nix')
-rw-r--r--tests/lang/eval-okay-hash.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/lang/eval-okay-hash.nix b/tests/lang/eval-okay-hash.nix
new file mode 100644
index 000000000000..2fff17f849bb
--- /dev/null
+++ b/tests/lang/eval-okay-hash.nix
@@ -0,0 +1,7 @@
+let
+  md5 = builtins.hashString "md5";
+  sha1 = builtins.hashString "sha1";
+  sha256 = builtins.hashString "sha256";
+  strings = [ "" "text 1" "text 2" ];
+in
+  (builtins.map md5 strings) ++ (builtins.map sha1 strings) ++ (builtins.map sha256 strings)