about summary refs log tree commit diff
path: root/tests/lang/eval-okay-attrnames.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/lang/eval-okay-attrnames.nix')
-rw-r--r--tests/lang/eval-okay-attrnames.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/tests/lang/eval-okay-attrnames.nix b/tests/lang/eval-okay-attrnames.nix
new file mode 100644
index 000000000000..978138f0c0d9
--- /dev/null
+++ b/tests/lang/eval-okay-attrnames.nix
@@ -0,0 +1,11 @@
+with import ./lib.nix;
+
+let
+
+  attrs = {y = "y"; x = "x"; foo = "foo";} // rec {x = "newx"; bar = x;};
+
+  names = builtins.attrNames attrs;
+
+  values = map (name: builtins.getAttr name attrs) names;
+
+in concat values