about summary refs log tree commit diff
path: root/tests/import-derivation.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/import-derivation.nix')
-rw-r--r--tests/import-derivation.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/tests/import-derivation.nix b/tests/import-derivation.nix
index 91adcd288f6e..44fa9a45d7e1 100644
--- a/tests/import-derivation.nix
+++ b/tests/import-derivation.nix
@@ -10,7 +10,10 @@ let
       '';
   };
 
-  value = import bar;
+  value =
+    # Test that pathExists can check the existence of /nix/store paths
+    assert builtins.pathExists bar;
+    import bar;
 
 in