about summary refs log tree commit diff
path: root/tests/import-derivation.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/import-derivation.nix')
-rw-r--r--tests/import-derivation.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/tests/import-derivation.nix b/tests/import-derivation.nix
new file mode 100644
index 000000000000..91adcd288f6e
--- /dev/null
+++ b/tests/import-derivation.nix
@@ -0,0 +1,23 @@
+with import ./config.nix;
+
+let
+
+  bar = mkDerivation {
+    name = "bar";
+    builder = builtins.toFile "builder.sh"
+      ''
+        echo 'builtins.add 123 456' > $out
+      '';
+  };
+
+  value = import bar;
+
+in
+
+mkDerivation {
+  name = "foo";
+  builder = builtins.toFile "builder.sh"
+    ''
+      echo -n FOO${toString value} > $out
+    '';
+}