about summary refs log tree commit diff
path: root/tests/export-graph.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/export-graph.nix')
-rw-r--r--tests/export-graph.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/tests/export-graph.nix b/tests/export-graph.nix
new file mode 100644
index 000000000000..3e30d2dcea7a
--- /dev/null
+++ b/tests/export-graph.nix
@@ -0,0 +1,23 @@
+with import ./config.nix;
+
+rec {
+
+  buildGraphBuilder = builtins.toFile "build-graph-builder"
+    ''
+      #cat refs
+      while read path; do
+          read drv
+          read nrRefs
+          echo "$path has $nrRefs references"
+          echo -n "$path" >> $out
+          for ((n = 0; n < $nrRefs; n++)); do read ref; echo "ref $ref"; done
+      done < refs
+    '';
+
+  buildGraph = mkDerivation {
+    name = "dependencies";
+    builder = buildGraphBuilder;
+    exportReferencesGraph = ["refs" (import ./dependencies.nix)];
+  };
+
+}