about summary refs log tree commit diff
path: root/tests/config.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/config.nix')
-rw-r--r--tests/config.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/config.nix b/tests/config.nix
index 76388fdd5b95..6ba91065b83d 100644
--- a/tests/config.nix
+++ b/tests/config.nix
@@ -13,7 +13,7 @@ rec {
     derivation ({
       inherit system;
       builder = shell;
-      args = ["-e" args.builder or (builtins.toFile "builder.sh" "eval \"$buildCommand\"")];
+      args = ["-e" args.builder or (builtins.toFile "builder.sh" "if [ -e .attrs.sh ]; then source .attrs.sh; fi; eval \"$buildCommand\"")];
       PATH = path;
     } // removeAttrs args ["builder" "meta"])
     // { meta = args.meta or {}; };