about summary refs log tree commit diff
path: root/tests/check.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/check.nix')
-rw-r--r--tests/check.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/tests/check.nix b/tests/check.nix
index 08aac2fb0a..56c82e565a 100644
--- a/tests/check.nix
+++ b/tests/check.nix
@@ -10,6 +10,11 @@ with import ./config.nix;
       '';
   };
 
+  hashmismatch = import <nix/fetchurl.nix> {
+    url = "file://" + toString ./dummy;
+    sha256 = "0mdqa9w1p6cmli6976v4wi0sw9r4p5prkj7lzfd1877wk11c9c73";
+  };
+
   fetchurl = import <nix/fetchurl.nix> {
     url = "file://" + toString ./lang/eval-okay-xml.exp.xml;
     sha256 = "0kg4sla7ihm8ijr8cb3117fhl99zrc2bwy1jrngsfmkh8bav4m0v";