about summary refs log tree commit diff
path: root/tests/build-hook.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/build-hook.nix')
-rw-r--r--tests/build-hook.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/tests/build-hook.nix b/tests/build-hook.nix
new file mode 100644
index 000000000000..666cc6ef8041
--- /dev/null
+++ b/tests/build-hook.nix
@@ -0,0 +1,22 @@
+with import ./config.nix;
+
+let
+
+  input1 = mkDerivation {
+    name = "build-hook-input-1";
+    builder = ./dependencies.builder1.sh;
+  };
+
+  input2 = mkDerivation {
+    name = "build-hook-input-2";
+    builder = ./dependencies.builder2.sh;
+  };
+
+in
+
+  mkDerivation {
+    name = "build-hook";
+    builder = ./dependencies.builder0.sh;
+    input1 = " " + input1 + "/.";
+    input2 = " ${input2}/.";
+  }