about summary refs log tree commit diff
path: root/tests/binary-patching.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/binary-patching.nix')
-rw-r--r--tests/binary-patching.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/tests/binary-patching.nix b/tests/binary-patching.nix
index afa0a0fb3f84..0de3028bd64d 100644
--- a/tests/binary-patching.nix
+++ b/tests/binary-patching.nix
@@ -8,8 +8,11 @@ mkDerivation {
     ''
       mkdir $out
       seq 1 1000000 > $out/foo
-      ${if version == 2 then ''
+      ${if version != 1 then ''
         seq 1000000 1010000 >> $out/foo
       '' else ""}
+      ${if version == 3 then ''
+        echo foobar >> $out/foo
+      '' else ""}
     '';
 }