about summary refs log tree commit diff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 000000000000..dc8c15e67134
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,19 @@
+TEST_ROOT = $(shell pwd)/test-tmp
+
+TESTS_ENVIRONMENT = TEST_ROOT=$(TEST_ROOT) \
+  NIX_STORE_DIR=$(TEST_ROOT)/store \
+  NIX_DATA_DIR=$(TEST_ROOT)/data \
+  NIX_LOG_DIR=$(TEST_ROOT)/log \
+  NIX_STATE_DIR=$(TEST_ROOT)/state \
+  NIX_DB_DIR=$(TEST_ROOT)/db \
+  TOP=$(shell pwd)/.. \
+  $(SHELL) -e -x
+
+simple.sh: simple.nix
+
+TESTS = init.sh simple.sh
+
+include ../substitute.mk
+
+EXTRA_DIST = \
+  simple.nix.in simple.builder.sh