about summary refs log tree commit diff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 3aa43417f1f3..c14b8a9210b0 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -5,12 +5,12 @@ extra1 = $(TEST_ROOT)/shared
 TESTS_ENVIRONMENT = TEST_ROOT=$(TEST_ROOT) \
   NIX_STORE_DIR=$(TEST_ROOT)/store \
   NIX_DATA_DIR=$(TEST_ROOT)/data \
-  NIX_LOG_DIR=$(TEST_ROOT)/log \
-  NIX_STATE_DIR=$(TEST_ROOT)/state \
+  NIX_LOCALSTATE_DIR=$(TEST_ROOT)/var \
+  NIX_LOG_DIR=$(TEST_ROOT)/var/log/nix \
+  NIX_STATE_DIR=$(TEST_ROOT)/var/nix \
   NIX_DB_DIR=$(TEST_ROOT)/db \
   NIX_BIN_DIR=$(TEST_ROOT)/bin \
   NIX_LIBEXEC_DIR=$(TEST_ROOT)/bin \
-  NIX_LOCALSTATE_DIR=$(TEST_ROOT)/state \
   REAL_BIN_DIR=$(bindir) \
   REAL_LIBEXEC_DIR=$(libexecdir) \
   REAL_LOCALSTATE_DIR=$(localstatedir) \